Share this project

Done

Share this project

Done
Low-cost and easy-to-use map-making software focused on creating gorgeous hi-resolution tile-based tactical-scale battlemaps.
Low-cost and easy-to-use map-making software focused on creating gorgeous hi-resolution tile-based tactical-scale battlemaps.
1,828 backers pledged $82,005 to help bring this project to life.

MapForge v1.0.2 now available

12 likes

Aside from fixing some bugs reported in v1.0 and v1.0.1 (particularly the losing-transparency-when stamping-Items bug), this release adds support for multi-part Add-Ons.

If you happen to have purchased either Gabriel Pickard's "Village" Add-On (which comes in 2 parts) and/or Studio Wyldfurr's "Dungeon Map Tiles" Add-On (which comes in 3 parts) AND have already input your registration code manually or claimed the registration codes from the server, you will need to do a little housekeeping to ensure things work as they should.

********************************************************************

Before launching MapForge, please delete the "Add-Ons.txt" file found here: C:\Users\username\AppData\LocalLow\Adobe\Director 11\MapForge\Prefs\

(the exact path varies under different versions of Windows, and depending on the compatibility mode you've selected for MapForge on 64-bit Windows)

Mac OS X users should look for that file here:

~User:Library:Application Support:Adobe:Director 11:MapForge:Prefs:

Then launch MapForge v1.0.2 and claim your registration codes from the server (don't input the codes manually).

Failure to delete the "Add-Ons.txt" file as mentioned above will likely lead to only Part 1 of the Add-On being available to you.

********************************************************************

The v1.0.2 update is available both as a patch for v1.0.1, and as a Full Install.

If you just need the patch, get it here:

For Windows (11.0 MB) 

For Mac (9.2 MB)

If you want a Full Install of v1.0.2, download it from the MapForge Downloads page.

Bruce Meyer, Jonas Schiött, and 10 more people like this update.

Comments

Only backers can post comments. Log In
    1. Battlegrounds Games, LLC 6-time creator on

      @Joshua, follow the instructions posted here to claim your MapForge license and Add-On registration codes:
      https://groups.google.com/d/msg/mapforge-user-group/VTYBdl7xeL0/bGl1-dK9AAAJ

    2. Johua De Santo on

      I am confused a bit. I got the publisher reward but I have no idea how to (I guess) get it up and running.

    3. Battlegrounds Games, LLC 6-time creator on

      I think I know what's going on with that. Definitely going to fix in v1.0.3.

    4. Missing avatar

      David Bettsack on

      Well, at least we know this is being pretty consistent between us then. Just something else to add to v1.0.3 :)

    5. Missing avatar

      PA on

      Ah, just tried that, wasn't really clear on what the error was. Thouht that they showed up was enough... They show up, but trying to place tiles I see "The asset missing: "SDTV Building 36 9x7"(GP4)", etc.. So, yea, it's not working as well as I thought. The items and tile overlays work, but they're duplicates of the Village 1.

      It's placing phantoms that get listed as placed but cause script errors if I try to select one. So, yea, sorry. Not working for me either.

    6. Missing avatar

      David Bettsack on

      @PA: Can you put down tiles from the 2-parter? I have the 3-part add-on and get a "missing asset" error, as does dragonwolf, whenever I try to actually use tiles from anything other than part 1.

    7. Missing avatar

      PA on

      OK, tried brand new with the Add-Ons I just downloaded, and they behaved as expected; showed up as "Unregistered Add-On" until I claimed the codes.

      The 2 parter add-on also works fine!

    8. Missing avatar

      PA on

      I found Add-Ons.txt's other location, since MapForge wasn't making one in LocalLow after I deleted it (even though deleting that file did make it so claiming the licenses returned a success.). It was in Roaming as well as LocalLow.

      It must have been in both places, because I just deleted the Roaming version and now things are behaving the way I expected them to, showing "Unregistered Add-On" that I can't do anything with.

      After doing a quick double check, yea, it's not a scaling issue with Jade Halls (we'd talked a little about it in e-mail). It's with MapForge--if I double click an item, use the slider to scale an item (say, to 50%), then hit "Done", it ends up *huge*, rather than the preview of half the size. S+arrow key scales things down correctly.

    9. Battlegrounds Games, LLC 6-time creator on

      @PA, half of this Update talks about how to unregister the Add-Ons. : P

      They should only be getting registered in one place, which is the "Add-Ons.txt" file. In your case, when I send you the IGG Add-Ons, try using them before registering them. When you're done testing, claim the reg codes from the server.

      Weird scaling issue with Jade Halls? There shouldn't be any weirdness, AFAIK.

    10. Missing avatar

      PA on

      I just double checked, and attempting to overwrite a file (with the proper extension) gave me the Error 179. Saving with a new name was fine.

      Is there a way for me to unregister my add-ons in order to test it? If the Add-Ons are being registered in two different places, it's probably just that deleting the Add-Ons.txt and re-registering them wasn't what unlocked them? Since I'd registered them a long while ago.

      Or, alternatively, since yes, I am due a good chunk of IGG Add-Ons, I can test those and make sure they don't come up as usable before they're registered.

      I'll keep in mind about the map resolution, and look forward to future options. I can get around the weird scaling issue with Jade Halls since I expect it.

    11. Weresheep of Sin AKA Stefan
      Superbacker
      on

      I'll have to test if the keyboard shortcuts that the program tells me to use actually work with the German keyboard layout - otherwise I would have to change it to ENG every time I use the program.

    12. Missing avatar

      David Bettsack on

      The _ might be there, even if you can't see it. The bottom of the characters seems to be below the visible box on my computer at least, so you just might not be able to see the _.

    13. Battlegrounds Games, LLC 6-time creator on

      Well, it wouldn't be every time you run MapForge. Just when you need to register a bunch of Add-Ons at once. : )

      Bummer if that workaround doesn't work for underscores, though.

    14. Weresheep of Sin AKA Stefan
      Superbacker
      on

      and not sure if "_" works even with ENG keyboard mode - it does not appear in the entry window at least.

    15. Weresheep of Sin AKA Stefan
      Superbacker
      on

      That might be a very temporary solution, which I do not want to use in the long-term ... i.e. please make sure your keyboard shortcuts work without foreign users having to switch their keyboards to ENG every time.

    16. Battlegrounds Games, LLC 6-time creator on

      @Weresheep, how about temporarily switching your computer keyboard to ENG mode to obtain the "@" using Shift-2? (suggested by another foreign user with the same problem)

    17. Battlegrounds Games, LLC 6-time creator on

      Nice to hear some positive feedback, PA.

      When saving, be sure to conserve the ".cxt" suffix at the end of the filename. Overwriting should be allowed, but perhaps that caused the failure? (I tend to "Save As" a lot, changing a number at the end).

      Was MapForge running when you deleted the Add-Ons.txt file? I can't see how you still had access to the content, otherwise (kinda scary).

      No way to randomize assets yet PRIOR to placing them. I hope to someday add options to randomize the asset, its size, its placement, and/or its rotation.

      Map resolution should be set before the map is created, for now, at least.

      No Add-On has yet had to be re-released aside from Rock Temple. Not saying it won't happen in the future.

      Do I owe you some IGG tiles?

    18. Missing avatar

      PA on

      Transparency works! Selecting Add-On script errors are fixed!

      I'm trying to save a map I put together real fast to test things, and I'm getting back "There was a problem saving the map using the specified file name. Error: 179". I got that error trying to save over an existing map as well as trying a new filename (neither of which were unusual--just "test.cxt" and "test2.cxt") Maybe caused by trying to save using an existing filename, and the error is just not informative for the user. Also possibly caused by saving a map made with unregistered add-ons!

      Then I realized I'd forgotten to re-register the add-ons after following the step to delete the "Add-On.txt". So I was using unregistered add-ons for a bit there, and that solved the save error for a new filename.

      Export works great. The panning and scrolling with right click and the mouse wheel feel good.

      I couldn't find a way to randomize an item while placing it, so I suggest something of that nature be added. It would be especially useful for item sets that contain ground cover or Kepli's trees.

      Selection tool remains slow measured in multiple seconds, depending on how many tiles are placed and also the add-on source, though it's somewhat improved from when I first reported it. Editing or applying filters to selected items is slow, but scaling and rotating an item, or applying filters to the stamp tool, before something is placed down is nice and fast. It's worst with Jade Halls, or with a lot of add-ons loaded.

      Resizing the DPI of a map from 50 to 200 crams all the tiles up into the top left corner.

      Was a fixed version of Jade Halls of Nys ever released? I remember you tracked some of the issues I was having to that specific add-on having the wrong DPI.

      Anyhow, now that 1.0 is actually working, I'm looking forward to getting the rest of the IGG tiles and making some maps :)

      For reference, my computer spec to try to help with figuring out why the select tool is unholy slow:
      Windows 10 Pro 64 bit
      AMD FX-6100 3.3GHz
      8 GB RAM
      NVIDIA GeForce GTX 970
      MapForge running as administrator in Windows XP Sp 3 compatibility mode on a HDD.

    19. Missing avatar

      David Bettsack on

      Like dragonwolf I am getting the missing asset error on multi-part add-ons, but not the whole other cascade of errors.

    20. Battlegrounds Games, LLC 6-time creator on

      Yes, it looks like I forgot to update the version number in the code, so this release will still say "v1.0.1" in the About panel.

    21. Weresheep of Sin AKA Stefan
      Superbacker
      on

      Nope, copy paste does not work and my keyboard is a typical German keyboard - which might indeed be the problem.

    22. Battlegrounds Games, LLC 6-time creator on

      @Weresheep, Are you using an unusual keyboard? It should be the Ctrl key that changes the current tool temporarily. Does copying and pasting your email address into the field work?

    23. Weresheep of Sin AKA Stefan
      Superbacker
      on

      when I press the "ALT Gr" key, the active button in the tool section shifts from "Stamp" to "Pan/Scroll". It does that also when the menu for entering the email is open, preventing the @ from being recognized.

    24. Weresheep of Sin AKA Stefan
      Superbacker
      on

      no NumLock, no CapsLock, even @ does not work ... instead the program seems to use the ALT Gr key (which I need to get the @) for a shortcut.

    25. Battlegrounds Games, LLC 6-time creator on

      @Weresheep, I'll look into the "_" (underscore) issue. I know the "@" symbol is accepted for sure. Make sure you don't have modifier keys enabled, like CapsLock, NumLock, etc.

    26. Weresheep of Sin AKA Stefan
      Superbacker
      on

      I might be making a mistake, but I seem to be unable to put in a working email address because the program fails to recognize the input of "_" and (more importantly) "@".

    27. Battlegrounds Games, LLC 6-time creator on

      @dragonwolf, thanks for the feedback, the screenshots, and the video captures. The WASD keys are already being used for something else (moving and nudging selected assets).

    28. Battlegrounds Games, LLC 6-time creator on

      @Robert, yeah, I didn't do anything in the last couple of releases to specifically improve the situation on High Sierra, but I was planning to make that the focus of v1.0.3 *assuming* v1.0.2 got things to a decent state for everyone else. But based on the feedback I'm getting below, my efforts might actually be making things worse, rather than better.

    29. Mr.Keltz
      Superbacker
      on

      I’ve kept questions to a minimum until it looked like you had a good handle on things. If someone could provide an update # for me to go back to or point in the direction of a FAQ so I can get my LiC and the latest full install , I would greatly appreciate it. Can’t wait to play around with this one! Thanks ahead of time!

    30. Missing avatar

      dragonwolf
      Superbacker
      on

      @ Renato - If you look at the properties of the Magforge.exe it should show file version 1.0.2.0, which means you are running the latest version. The internal code is still detecting version 1.0.1.0 though for update and display in the about box.

    31. Missing avatar

      Renato Da Conceicao on

      I downloaded it again twice tonight and it still shows v1.01

    32. Missing avatar

      dragonwolf
      Superbacker
      on

      I added another video to my link below using just the largest map pack I have, Hamlet-Outskirts. It clocks in at 1.4GB. All different kinds of issues.

    33. Missing avatar

      dragonwolf
      Superbacker
      on

      Installed patch. Prompted that a 1.0.2 upgrade is available. About Box still shows V 1.0.1. Transparency appears to be fixed. Having the scroll wheel to zoom is nice as is right-click to pan. Now, using the arrow keys to switch between items in a set is awkward. What about using the normal WASD keys that pretty much every game uses to have WS switch categories on the right and AD to switch between items in a set. Those keys are much easier to use in tandem with a mouse than the arrow keys.
      I re-added my Add-Ons and loaded the GP Villages and both 1 and 2 showed up. I stamped a bunch of houses down. Much quicker than previously. After I had stamped 20 or so down, I experienced a hang after I had switched to Village 2 and then used right-click to pan. I lost the visual of the item by the cursor and the app froze up for 15 seconds or so. When it unfroze, the visual by the cursor came back so I tried stamping again and it froze and then displayed an error about the asset missing. I tried several times and got the same failure. I switched back to Village 1 and got none of the items visible on the bottom scroll area. I tried to stamp the building 1 and it did stamp it down, but it froze a little and then displayed the missing asset error. I used the right arrow key to change to a different version of the building and they showed back up on the bottom scroll, but the scroll area was messed up.
      I recorded some videos showing the asset issues and the lag. In the first video, I forgot to include the cursor so you can't see me circling it around waiting. You can in the second video though. There's also some screenshots I grabbed.

      https://1drv.ms/f/s!AvdxuIrPjfZNkqkj7J3-6NqJTrInzA

    34. Missing avatar

      Robert Tharp
      Superbacker
      on

      Slight progress on a 2017 iMac Retina, OS 10.13.4, program now attempts to open, flashes a roughly VGA sized screen in black w/white guide lines, then crashes... so 1.0.2 is still having issues w/High Sierra. OTOH, at least it flashed a screen and didn't through a 'file not found' error.

    35. John Tuck Davison on

      This is just a re-post from the previous page since I posted it right before this update came out. Sorry for the spam.

      Bug Report:
      1) Program doesn't redraw the screen properly when resizing it from Window to full screen. (I have a large 4K screen)
      2) Tiles disappear when resizing the screen. Have to switch the add on and come back for them to reappear
      3) Lag only shows itself depending on the map size. On a 50 x 50 the lag is horrendous about 10 sec in between and I have 32 GB of ram and a Geforce GTX 960 card. Almost no lag on a smaller size map.
      4) Worst of all - I had to disable several add-ons because the program couldn't even start with all of them. Now that I have reenabled some of them it says that the add-ons are not registered and
      re-registering it with my email won't work as well. THIS HONESTLY IS RIDICULUS because at this stage of buggyness there shouldn't even be copyright protection. See comment below for my input on the
      matter
      5) Following error occurs when I exit the program after exporting a map
      Object expected Void Script Error. Continue?
      6) This bug only showed up when I put the ad-ons back and it said they were not registered
      List expected for handler
      #count
      Script Error. Continue?
      7) Some add-ons say they have no tiles, but I know they do and have to again and again be reselected in the list for them to show up
      Suggestions
      1) Go back and call this a beta version. It is not a big deal, but people really deserve to know this
      2) If DRM is an issue I would like to suggest that you take the program to Steam and sell the add-ons as packages. That way you get the DRM and we won’t have to deal with it constantly malfunctioning it.
      3) I advise you(us) that we limit ourselves to a few tilesets and that you provide a check list for all the features so that we can test it through and go step by step. That way we can address serious issues first and make the program stable.
      4) This is more a question: Did the Donjon integration feature already make it to MapForge or is it coming later.
      5) Yes, a tutorial video would be nice for everyone.
      On a positive note I would like to add that after the patch I was able to create some nice maps which I will soon use for my game. I am not unhappy that I crowdfunded this project and I want to tell you and everyone else that good things take time and as long as you are working on it and it gets better with every iteration I am willing to wait and have the patience to see this program come to its conclusion. As long as there is improvement on a regular basis I say this will be an amazing program when it is finished.

    36. John Tuck Davison on

      This version is now completely unusable tiles don't show up at all when I try to place them. I followed the guide to update but when I launch the program it still says there is a new version available. I tried to update via patch first then did a reinstall.

    37. Battlegrounds Games, LLC 6-time creator on

      @Micheal, as noted on the Downloads page, v1.0.3 will probably focus on getting it working consistently on High Sierra. To clarify, though, MapForge DOES work on Mac, up through Sierra, and it seems to work for a few users on High Sierra. It might be worth a try to install MapForge on an HFS+ format external drive and see if it runs from there. My suspicion is that the new Apple File System (APFS) is tripping things up in High Sierra.

    38. Missing avatar

      David Bettsack on

      Thanks for keep at this over the weekend!

    39. Michael Williams on

      still doesn't work on the Mac, any update or something i can help with?