Share this project

Done

Share this project

Done
Allows RPG gamers, authors and developers to create detailed fantasy maps quickly using an intuitive UI and specialized tools
Allows RPG gamers, authors and developers to create detailed fantasy maps quickly using an intuitive UI and specialized tools
724 backers pledged $26,823 to help bring this project to life.

Mac Beta Released!

Posted by Three Minds Software (Creator)
5 likes
First Mac Beta Release
First Mac Beta Release
We’re happy to announce that the Mac Beta has been released! Finally, right? We want thank everyone for your patience and encouragement!
This release means Other World Mapper now includes the Mac Beta as a download option. We will be sending out new emails. If you have any problems downloading the Mac version please contact us. Please, do not repurchase!

This is an early beta so please expect issues! We have known issues going into this Beta. A list of known issues is included in the release notes.

We encourage you to look for bugs! We really want to make this program as solid and bug free as possible! If you haven’t already, please join our forum or Facebook group to report any issues you find. 

Please note that right now only Sierra and High Sierra are supported. We were trying to get a build for El Capitan but it was taking too long and we didn't want to delay any longer. Let us know if you need support for El Capitain.

For Linux users, we do not have a Linux release yet. However, the port to Mac is actually a cross platform port. That means Linux isn’t far behind! We’ll have information for you soon! 

 -The Three Minds Software Team
Terri, Jeanne, and 3 more people like this update.

Comments

Only backers can post comments. Log In
    1. Missing avatar

      Joshua Lepard on

      Have been trying to use the Mac version of the program all week, and I get about an hour into my process and the program "unexpectedly quits" as the error message reads. Have been unable to complete or save a single map. Just wanted to let you guys know about this issue so it may be resolved soon!

    2. Three Minds Software Creator on

      @Fred Furtado There is basically one dependency that is the problem, the OWM engine and the UI library work down to 10.7. We'll continue working on adding support for as old of OS as we manage with that dependency.

      Meanwhile, the people that are running Sierra and High Sierra are finding issues that we'll get to address so we wanted to have a release in people's hand rather than delay while we worked on support for the older OS's :)

    3. Fred Furtado on

      I guess I'm screwed -- I'm still running Yosemite (10.10). Any chance of a compatible version?

    4. Three Minds Software Creator on

      @Christian B As we mentioned in the update, support for El Capitan (10.11) has been challenging particularly as we also need to keep Mojave in mind going forward, but we are going to continue working on that as we get further along the Beta. Also trying to get a sense of how many people are still running 10.11.

    5. Missing avatar

      Christian B on

      "This application requires MacOS 10.12, you have 10.11". Grumble. Not going to upgrade, unless I have to. Every upgrade with Apple gives you one thing, and takes two things away.

    6. Lisa Owen on

      Yes!! Yes!! Yes!!

    7. Missing avatar

      Joshua Lepard on

      FINALLY! Almost forgot I backed this years ago, and now I get my first chance to test out the program, can't wait!

    8. Missing avatar

      Christian B on

      Whee! This is the reason I backed. Cant wait to try it, after handling thousands of real life matters...sigh.

    9. Rob Lang on

      Yay! This is the reason I backed this project. Way back when.

      Awesome. Will test.